<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8">
<meta http-equiv="X-UA-Compatible" content="IE=edge" />
<script src="/cdn-cgi/apps/head/btP16gY7tNRVsMSs5HVVNKBORhs.js"></script><link rel="profile" href="http://gmpg.org/xfn/11">
<title>Jimmy Dore interviews Oliver Stone about Russia Gate, his recent interview with Putin and the backlash he&#8217;s received for interviewing Putin. &#8211; Investment Watch Blog</title>
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//cdn.rawgit.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Investment Watch Blog &raquo; Feed" href="http://www.investmentwatchblog.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Investment Watch Blog &raquo; Comments Feed" href="http://www.investmentwatchblog.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Investment Watch Blog &raquo; Jimmy Dore interviews Oliver Stone about Russia Gate, his recent interview with Putin and the backlash he&#8217;s received for interviewing Putin. Comments Feed" href="http://www.investmentwatchblog.com/jimmy-dore-interviews-oliver-stone-about-russia-gate-his-recent-interview-with-putin-and-the-backlash-hes-received-for-interviewing-putin/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.investmentwatchblog.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.5"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<script>
					advanced_ads_ready=function(){var fns=[],listener,doc=typeof document==="object"&&document,hack=doc&&doc.documentElement.doScroll,domContentLoaded="DOMContentLoaded",loaded=doc&&(hack?/^loaded|^c/:/^loaded|^i|^c/).test(doc.readyState);if(!loaded&&doc){listener=function(){doc.removeEventListener(domContentLoaded,listener);window.removeEventListener("load",listener);loaded=1;while(listener=fns.shift())listener()};doc.addEventListener(domContentLoaded,listener);window.addEventListener("load",listener)}return function(fn){loaded?setTimeout(fn,0):fns.push(fn)}}();
			</script><style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wpsr_main_css-css' href='http://www.investmentwatchblog.com/wp-content/plugins/wp-socializer/public/css/wp-socializer.min.css?ver=3.3.4' type='text/css' media='all' />
<link rel='stylesheet' id='wpsr_sb_fa_css-css' href='https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css?ver=4.9.5' type='text/css' media='all' />
<link rel='stylesheet' id='wpsr_sb_css-css' href='https://cdn.rawgit.com/vaakash/socializer/aaa23968/css/socializer.min.css?ver=4.9.5' type='text/css' media='all' />
<link rel='stylesheet' id='generate-style-grid-css' href='http://www.investmentwatchblog.com/wp-content/themes/generatepress/css/unsemantic-grid.min.css?ver=2.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='generate-style-css' href='http://www.investmentwatchblog.com/wp-content/themes/generatepress/style.min.css?ver=2.0.2' type='text/css' media='all' />
<style id='generate-style-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='generate-mobile-style-css' href='http://www.investmentwatchblog.com/wp-content/themes/generatepress/css/mobile.min.css?ver=2.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-essentials-css' href='http://www.investmentwatchblog.com/wp-content/themes/generatepress/css/font-awesome-essentials.min.css?ver=4.7' type='text/css' media='all' />
<link rel='stylesheet' id='generate-blog-css' href='http://www.investmentwatchblog.com/wp-content/plugins/gp-premium/blog/functions/css/style-min.css?ver=1.5.6' type='text/css' media='all' />
<script type='text/javascript' src='http://www.investmentwatchblog.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://www.investmentwatchblog.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://www.investmentwatchblog.com/wp-content/plugins/advanced-ads/public/assets/js/advanced.js?ver=1.8.28'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var advanced_ads_responsive = {"reload_on_resize":"0"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.investmentwatchblog.com/wp-content/plugins/advanced-ads-responsive/public/assets/js/script.js?ver=1.7.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var advanced_ads_pro_visitor_conditions = {"referrer_cookie_name":"advanced_ads_pro_visitor_referrer","referrer_exdays":"365","page_impr_cookie_name":"advanced_ads_page_impressions","page_impr_exdays":"3650"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.investmentwatchblog.com/wp-content/plugins/advanced-ads-pro/modules/advanced-visitor-conditions/inc/conditions.min.js?ver=2.1.3'></script>
<script type='text/javascript' src='http://www.investmentwatchblog.com/wp-content/plugins/advanced-ads-pro/modules/click-fraud-protection/assets/js/cfp.min.js?ver=2.1.3'></script>
<link rel='https://api.w.org/' href='http://www.investmentwatchblog.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.investmentwatchblog.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.investmentwatchblog.com/wp-includes/wlwmanifest.xml" />
<link rel='prev' title='Trump Just Hired HUGE Controversial Fox News Host For Special Job' href='http://www.investmentwatchblog.com/trump-just-hired-huge-controversial-fox-news-host-for-special-job/' />
<link rel='next' title='Canadian journalist at the U.N. exposes US MSM agenda succinctly and exposes &#8216;White Hats&#8217; in Syria' href='http://www.investmentwatchblog.com/canadian-journalist-at-the-u-n-exposes-us-msm-agenda-succinctly-and-exposes-white-hats-in-syria/' />
<meta name="generator" content="WordPress 4.9.5" />
<link rel="canonical" href="http://www.investmentwatchblog.com/jimmy-dore-interviews-oliver-stone-about-russia-gate-his-recent-interview-with-putin-and-the-backlash-hes-received-for-interviewing-putin/" />
<link rel='shortlink' href='http://www.investmentwatchblog.com/?p=810567' />
<script type="text/javascript">
		;var advadsCfpQueue = [], advadsCfpExpHours = 3;
		var advadsCfpClickLimit = 3;
		;
		var advadsCfpPath = '';
		var advadsCfpDomain = 'www.investmentwatchblog.com';
		var advadsCfpAd = function( adID ){
			if ( 'undefined' == typeof advadsProCfp ) { advadsCfpQueue.push( adID ) } else { advadsProCfp.addElement( adID ) }
		};
		</script><style type='text/css'>.rp4wp-related-posts ul{width:100%;padding:0;margin:0;float:left;}
.rp4wp-related-posts ul>li{list-style:none;padding:0;margin:0;padding-bottom:20px;clear:both;}
.rp4wp-related-posts ul>li>p{margin:0;padding:0;}
.rp4wp-related-post-image{width:35%;padding-right:25px;-moz-box-sizing:border-box;-webkit-box-sizing:border-box;box-sizing:border-box;float:left;}</style>
<meta name="viewport" content="width=device-width, initial-scale=1"><link rel="icon" href="http://www.investmentwatchblog.com/wp-content/uploads/2018/03/logo81-1-150x130.jpg" sizes="32x32" />
<link rel="icon" href="http://www.investmentwatchblog.com/wp-content/uploads/2018/03/logo81-1.jpg" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="http://www.investmentwatchblog.com/wp-content/uploads/2018/03/logo81-1.jpg" />
<meta name="msapplication-TileImage" content="http://www.investmentwatchblog.com/wp-content/uploads/2018/03/logo81-1.jpg" />
<style type="text/css" id="wp-custom-css">
			.post.sticky {
    -webkit-box-shadow: 10px 10px 5px 0px rgba(0,0,0,0.75);
    -moz-box-shadow: 10px 10px 5px 0px rgba(0,0,0,0.75);
    box-shadow: 10px 10px 5px 0px rgba(0,0,0,0.75);
}
		</style>

</head>
<body itemtype='http://schema.org/Blog' itemscope='itemscope' class="post-template-default single single-post postid-810567 single-format-standard wp-custom-logo post-image-below-header post-image-aligned-center sticky-menu-fade  featured-image-active right-sidebar nav-below-header fluid-header separate-containers active-footer-widgets-0 nav-aligned-left header-aligned-left dropdown-hover">
<a class="screen-reader-text skip-link" href="#content" title="Skip to content">Skip to content</a> <header itemtype="http://schema.org/WPHeader" itemscope="itemscope" id="masthead" class="site-header">
<div class="inside-header grid-container grid-parent">
<div class="header-widget">
<aside id="custom_html-8" class="widget_text widget inner-padding widget_custom_html"><div class="textwidget custom-html-widget"><script type="text/javascript" src="//s.ntv.io/serve/load.js" async></script>
</div></aside> </div>
<div class="site-branding">
<p class="site-description">
Spreading the truth. Empowering the people.
</p>
</div><div class="site-logo">
<a href="http://www.investmentwatchblog.com/" title="Investment Watch Blog" rel="home">
<img class="header-image" alt="Investment Watch Blog" src="http://www.investmentwatchblog.com/wp-content/uploads/2018/03/logo81.jpg" title="Investment Watch Blog" srcset="http://www.investmentwatchblog.com/wp-content/uploads/2018/03/logo81.jpg 1x, http://www.investmentwatchblog.com/wp-content/uploads/2018/03/logo81-1.jpg 2x" width="205" height="130" />
</a>
</div><div style="text-align: center; " id="inves-363794820">
<script type="text/javascript">
    var page_count = 'off';
    if (typeof OAS_rdl == 'undefined') {
        var OAS_rdl = '';
        var OAS_CA = '';
        page_count = 'on';
        document.write('<script type="text/javascript" src="https://oascentral.investingmediasolutions.com/Scripts/oas_analytics.js"></scr' + 'ipt>');
    } 
</script>
<script type="text/javascript">
    var OAS_url = 'https://oascentral.investingmediasolutions.com';
    var OAS_sitepage = 'InvestmentWatchBlog';
    var OAS_pos = 'Top';
    var OAS_searchterms = '';
    var OAS_taxonomy = '';
    if (typeof OAS_RNS == 'undefined'){
        var OAS_RN = new String (Math.random());
        var OAS_RNS = OAS_RN.substring(2, 11);
    }
    if (OAS_searchterms != '') { OAS_searchterms += '&'; }
    if (OAS_taxonomy != '') { OAS_taxonomy = '&' + OAS_taxonomy; }
    if (page_count != 'on') { OAS_taxonomy = '&oas_pv=no_analytics' + OAS_taxonomy; }
    document.write('<script type="text/javascript" src="' + OAS_url + '/RealMedia/ads/adstream_jx.ads/' + OAS_sitepage + '/1' + OAS_RNS + '@' + OAS_pos + '?' + OAS_searchterms + 'XE' + OAS_taxonomy + OAS_rdl + '&if_nt_CookieAccept=' + OAS_CA + '&XE"></scr' + 'ipt>');
</script>
</div> </div>
</header>
<nav itemtype="http://schema.org/SiteNavigationElement" itemscope="itemscope" id="site-navigation" class="main-navigation">
<div class="inside-navigation grid-container grid-parent">
<button class="menu-toggle" aria-controls="primary-menu" aria-expanded="false">
<span class="mobile-menu">Menu</span>
</button>
<div id="primary-menu" class="main-nav">
<ul class="menu sf-menu">
<li class="page_item page-item-2"><a href="http://www.investmentwatchblog.com/newsletters/">Newsletters</a></li>
<li class="page_item page-item-796053"><a href="http://www.investmentwatchblog.com/contact-us/">Contact US</a></li>
<li class="page_item page-item-795565"><a href="http://www.investmentwatchblog.com/economic-calendar/">Economic Calendar</a></li>
<li class="page_item page-item-795567"><a href="http://www.investmentwatchblog.com/submit-news-tips/">Submit News Tips</a></li>
<li class="page_item page-item-795569"><a href="http://www.investmentwatchblog.com/sponsored/">Sponsored</a></li>
<li class="page_item page-item-795571"><a href="http://www.investmentwatchblog.com/privacy-policy/">Privacy Policy</a></li>
</ul>
</div>
</div>
</nav>
<div id="page" class="hfeed site grid-container container grid-parent">
<div id="content" class="site-content">
<div id="primary" class="content-area grid-parent mobile-grid-100 grid-75 tablet-grid-75">
<main id="main" class="site-main">
<article id="post-810567" class="post-810567 post type-post status-publish format-standard has-post-thumbnail hentry category-all tag-about tag-interviews tag-jimmy tag-oliver tag-recent tag-russia tag-stone" itemtype='http://schema.org/CreativeWork' itemscope='itemscope'>
<div class="inside-article">
<header class="entry-header">
<h1 class="entry-title" itemprop="headline">Jimmy Dore interviews Oliver Stone about Russia Gate, his recent interview with Putin and the backlash he&#8217;s received for interviewing Putin.</h1> <div class="entry-meta">
<span class="posted-on"><a href="http://www.investmentwatchblog.com/jimmy-dore-interviews-oliver-stone-about-russia-gate-his-recent-interview-with-putin-and-the-backlash-hes-received-for-interviewing-putin/" title="9:34 am" rel="bookmark"><time class="entry-date published" datetime="2018-04-12T09:34:26+00:00" itemprop="datePublished">April 12, 2018</time></a></span> <span class="byline"><span class="author vcard" itemtype="http://schema.org/Person" itemscope="itemscope" itemprop="author">by <a class="url fn n" href="http://www.investmentwatchblog.com/author/maizipeng/" title="View all posts by IWB" rel="author" itemprop="url"><span class="author-name" itemprop="name">IWB</span></a></span></span> </div>
</header>
<div class="entry-content" itemprop="text">
<div class="inves-media-ads-before-the-post" id="inves-732406936">
<script type="text/javascript">
    var page_count = 'off';
    if (typeof OAS_rdl == 'undefined') {
        var OAS_rdl = '';
        var OAS_CA = '';
        page_count = 'on';
        var script = document.createElement('script');
        script.src = 'http://oascentral.investingmediasolutions.com/Scripts/oas_analytics.js';
        document.write(script.outerHTML);
    } 
</script>
<script type="text/javascript">
    var OAS_url = 'http://oascentral.investingmediasolutions.com';
    var OAS_sitepage = 'InvestmentWatchBlog_Mobile';
    var OAS_pos = 'TopRight';
    var OAS_searchterms = '';
    var OAS_taxonomy = '';
    if (typeof OAS_RNS == 'undefined'){
        var OAS_RN = new String (Math.random());
        var OAS_RNS = OAS_RN.substring(2, 11);
    }
    if (OAS_searchterms != '') { OAS_searchterms += '&'; }
    if (OAS_taxonomy != '') { OAS_taxonomy = '&' + OAS_taxonomy; }
    if (page_count != 'on') { OAS_taxonomy = '&oas_pv=no_analytics' + OAS_taxonomy; }
     var script2 = document.createElement('script');
    script2.src = OAS_url + '/RealMedia/ads/adstream_jx.ads/' + OAS_sitepage + '/1' + OAS_RNS + '@' + OAS_pos + '?' + OAS_searchterms + 'XE' + OAS_taxonomy + OAS_rdl + '&if_nt_CookieAccept=' + OAS_CA + '&XE';
    document.write(script2.outerHTML);
</script></div><div class="wp-socializer wpsr-buttons"><span class="wpsr-btn wpsr-srvc-share_counter"><div class="wpsr-counter "><span class="scount" style="color:#000"><span data-wpsrs-cached="true">1</span></span><small class="stext">Shares</small></div></span><span class="wpsr-btn wpsr-srvc-social_buttons"><div class="socializer sr-32px sr-ribbon sr-opacity sr-icon-white sr-count-1 sr-pad sr-popup"><span class="sr-facebook sr-text-in"><a rel="nofollow" href="https://www.facebook.com/share.php?u=http://www.investmentwatchblog.com/jimmy-dore-interviews-oliver-stone-about-russia-gate-his-recent-interview-with-putin-and-the-backlash-hes-received-for-interviewing-putin/" target="_blank" title="Share this on Facebook"><i class="fa fa-facebook"></i><span class="ctext"><span data-wpsrs-cached="true">1</span></span></a></span>
<span class="sr-twitter "><a rel="nofollow" href="https://twitter.com/home?status=Jimmy%20Dore%20interviews%20Oliver%20Stone%20about%20Russia%20Gate,%20his%20recent%20interview%20with%20Putin%20and%20the%20backlash%20he%E2%80%99s%20received%20for%20interviewing%20Putin.%20-%20http://www.investmentwatchblog.com/?p=810567%20" target="_blank" title="Tweet this !"><i class="fa fa-twitter"></i></a></span>
<span class="sr-email "><a rel="nofollow" href="mailto:?to=&amp;subject=Jimmy%20Dore%20interviews%20Oliver%20Stone%20about%20Russia%20Gate,%20his%20recent%20interview%20with%20Putin%20and%20the%20backlash%20he%E2%80%99s%20received%20for%20interviewing%20Putin.&amp;body=Oliver%20Stone%20is%20probably%20one%20of%20the%20most%20tactful%20conspiracy%20theorists%20around.%20The%20fact%20he%20recently%20i%20-%20http://www.investmentwatchblog.com/jimmy-dore-interviews-oliver-stone-about-russia-gate-his-recent-interview-with-putin-and-the-backlash-hes-received-for-interviewing-putin/" target="_blank" title="Email this "><i class="fa fa-envelope"></i></a></span>
<span class="sr-stumbleupon "><a rel="nofollow" href="https://www.stumbleupon.com/submit?url=http://www.investmentwatchblog.com/jimmy-dore-interviews-oliver-stone-about-russia-gate-his-recent-interview-with-putin-and-the-backlash-hes-received-for-interviewing-putin/&amp;title=Jimmy%20Dore%20interviews%20Oliver%20Stone%20about%20Russia%20Gate,%20his%20recent%20interview%20with%20Putin%20and%20the%20backlash%20he%E2%80%99s%20received%20for%20interviewing%20Putin." target="_blank" title="Submit this to StumbleUpon"><i class="fa fa-stumbleupon"></i></a></span>
<span class="sr-shortlink "><a rel="nofollow" href="http://www.investmentwatchblog.com/?p=810567" target="_blank" onclick="socializer_shortlink( event, this )" title="Short link"><i class="fa fa-link"></i></a></span></div></span></div><div class="wp-socializer wpsr-buttons"><span class="wpsr-btn wpsr-srvc-facebook"><div class="fb-like" data-href="http://www.investmentwatchblog.com/jimmy-dore-interviews-oliver-stone-about-russia-gate-his-recent-interview-with-putin-and-the-backlash-hes-received-for-interviewing-putin/" data-width="" data-layout="button_count" data-action="like" data-show-faces="false" data-share="false" data-size="small"></div></span><span class="wpsr-btn wpsr-srvc-twitter"><a href="https://twitter.com/share" class="twitter-share-button" data-show-count="false" data-related="" data-url="http://www.investmentwatchblog.com/jimmy-dore-interviews-oliver-stone-about-russia-gate-his-recent-interview-with-putin-and-the-backlash-hes-received-for-interviewing-putin/" data-size="small" data-via="" data-hashtags="">Tweet</a></span><span class="wpsr-btn wpsr-srvc-pocket"><a data-pocket-label="pocket" data-pocket-count="horizontal" class="pocket-btn" data-save-url="http://www.investmentwatchblog.com/jimmy-dore-interviews-oliver-stone-about-russia-gate-his-recent-interview-with-putin-and-the-backlash-hes-received-for-interviewing-putin/" data-lang="en">Pocket</a><script type="text/javascript">!function(d,i){if(!d.getElementById(i)){var j=d.createElement("script");j.id=i;j.src="https://widgets.getpocket.com/v1/j/btn.js?v=1";var w=d.getElementById(i);d.body.appendChild(j);}}(document,"pocket-btn-js");</script></span></div><p>Oliver Stone is probably one of the most tactful conspiracy theorists around. The fact he recently interviewed Putin is enough for anyone to turn their ear up.</p>
<p><iframe width="1024" height="576" src="https://www.youtube.com/embed/9tIeKzOL_Qw?feature=oembed" frameborder="0" allow="autoplay; encrypted-media" allowfullscreen></iframe></p>
<p><iframe width="1024" height="576" src="https://www.youtube.com/embed/9tIeKzOL_Qw?feature=oembed" frameborder="0" allow="autoplay; encrypted-media" allowfullscreen></iframe></p>
<div class="inves-after-content" id="inves-1786329978">
<iframe width="488" height="114" scrolling="NO" src="//www.dianomi.com/smartads.epl?id=3387" style="width: 100%; border: none; overflow: hidden;"></iframe>

<iframe width="754" height="550" scrolling="NO" src="//www.dianomi.com/smartads.epl?id=3375" style="width: 100%; border: none; overflow: hidden;"></iframe>
<div id="ld-sbs-cntnr-8976-7087"></div>
<script async data-cfasync="false" src='https://cdn1.lockerdome.com/embeds/investmentwatchblog_main_content_multi_impression_unit.js'></script>
833 views</div><div class='rp4wp-related-posts'>
<h3>More Stories You May Like:</h3>
<ul>
<li><div class='rp4wp-related-post-image'>
<a href='http://www.investmentwatchblog.com/putin-again-outsmarts-the-west/'></a></div>
<div class='rp4wp-related-post-content'>
<a href='http://www.investmentwatchblog.com/putin-again-outsmarts-the-west/'>Putin Again Outsmarts the West</a></div>
</li>
<li><div class='rp4wp-related-post-content'>
<a href='http://www.investmentwatchblog.com/russia-putin-let-he-who-is-without-guilt-cast-the-first-stone/'>RUSSIA &amp; PUTIN: let he who is without guilt cast the first stone</a></div>
</li>
<li><div class='rp4wp-related-post-image'>
<a href='http://www.investmentwatchblog.com/vladimir-putin-george-soros-is-wanted-dead-or-alive/'></a></div>
<div class='rp4wp-related-post-content'>
<a href='http://www.investmentwatchblog.com/vladimir-putin-george-soros-is-wanted-dead-or-alive/'>Vladimir Putin: George Soros Is Wanted “Dead Or Alive”</a></div>
</li>
<li><div class='rp4wp-related-post-image'>
<a href='http://www.investmentwatchblog.com/jason-chaffetz-destroys-ex-clinton-state-staffer-over-trump-putin-relationship/'><img width="150" height="150" src="http://www.investmentwatchblog.com/wp-content/uploads/2018/04/0-86-150x150.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" /></a></div>
<div class='rp4wp-related-post-content'>
<a href='http://www.investmentwatchblog.com/jason-chaffetz-destroys-ex-clinton-state-staffer-over-trump-putin-relationship/'>Jason Chaffetz Destroys Ex Clinton State Staffer Over Trump Putin Relationship</a></div>
</li>
<li><div class='rp4wp-related-post-image'>
<a href='http://www.investmentwatchblog.com/dutch-foreign-minister-admits-he-made-up-fake-news-about-putin/'></a></div>
<div class='rp4wp-related-post-content'>
<a href='http://www.investmentwatchblog.com/dutch-foreign-minister-admits-he-made-up-fake-news-about-putin/'>Dutch Foreign Minister admits he made up fake news about Putin</a></div>
</li>
</ul>
</div>
<div class="inves-content-middle" style="text-align: center; " id="inves-2016255767">
<iframe width="488" height="114" scrolling="NO" src="//www.dianomi.com/smartads.epl?id=3387" style="width: 100%; border: none; overflow: hidden;"></iframe>
</div><script>( window.advanced_ads_ready || jQuery( document ).ready ).call( null, function() {var advads_content_p = jQuery("#inves-2016255767").parent().find("p:not(table p):not(blockquote p):not(div.wp-caption p)").filter(function(){return jQuery.trim(this.innerHTML)!==""});var advads_content_center_p = advads_content_p.eq( Math.round( ( advads_content_p.length - 3 ) / 2 ) );if( advads_content_center_p.length ) { advads.move("#inves-2016255767", advads_content_center_p, { method: "insertAfter" }); }});</script> </div>
<footer class="entry-meta">
<span class="tags-links"><span class="screen-reader-text">Tags </span><a href="http://www.investmentwatchblog.com/tag/about/" rel="tag">about</a>, <a href="http://www.investmentwatchblog.com/tag/interviews/" rel="tag">interviews</a>, <a href="http://www.investmentwatchblog.com/tag/jimmy/" rel="tag">jimmy</a>, <a href="http://www.investmentwatchblog.com/tag/oliver/" rel="tag">oliver</a>, <a href="http://www.investmentwatchblog.com/tag/recent/" rel="tag">recent</a>, <a href="http://www.investmentwatchblog.com/tag/russia/" rel="tag">russia</a>, <a href="http://www.investmentwatchblog.com/tag/stone/" rel="tag">stone</a></span> <nav id="nav-below" class="post-navigation">
<span class="screen-reader-text">Post navigation</span>
<div class="nav-previous"><span class="prev" title="Previous"><a href="http://www.investmentwatchblog.com/trump-just-hired-huge-controversial-fox-news-host-for-special-job/" rel="prev">Trump Just Hired HUGE Controversial Fox News Host For Special Job</a></span></div><div class="nav-next"><span class="next" title="Next"><a href="http://www.investmentwatchblog.com/canadian-journalist-at-the-u-n-exposes-us-msm-agenda-succinctly-and-exposes-white-hats-in-syria/" rel="next">Canadian journalist at the U.N. exposes US MSM agenda succinctly and exposes &#8216;White Hats&#8217; in Syria</a></span></div> </nav>
</footer>
</div>
</article>
<div class="comments-area">

<div class="dcl-disqus-thread" id="comments">
<div id="disqus_thread">
</div>
</div>
<script type="text/javascript">
	/* <![CDATA[ */
		var disqus_url = 'http://www.investmentwatchblog.com/jimmy-dore-interviews-oliver-stone-about-russia-gate-his-recent-interview-with-putin-and-the-backlash-hes-received-for-interviewing-putin/';
		var disqus_identifier = '810567 http://www.investmentwatchblog.com/?p=810567';
		var disqus_container_id = 'disqus_thread';
		var disqus_domain = 'disqus.com';
		var disqus_shortname = 'investmentwatchblog';
		var disqus_title = "Jimmy Dore interviews Oliver Stone about Russia Gate, his recent interview with Putin and the backlash he&#8217;s received for interviewing Putin.";
		var disqus_config = function () {
			var config = this; // Access to the config object
			config.language = '';

			/* Add the ability to add javascript callbacks */
			
			/*
			   All currently supported events:
				* preData — fires just before we request for initial data
				* preInit - fires after we get initial data but before we load any dependencies
				* onInit  - fires when all dependencies are resolved but before dtpl template is rendered
				* afterRender - fires when template is rendered but before we show it
				* onReady - everything is done
			 */

			config.callbacks.preData.push(function() {
				// clear out the container (its filled for SEO/legacy purposes)
				document.getElementById(disqus_container_id).innerHTML = '';
			});
								};
	/* ]]> */
	</script>
<script type="text/javascript">
	/* <![CDATA[ */
		var DsqLocal = {
			'trackbacks': [
				],
			'trackback_url': "http:\/\/www.investmentwatchblog.com\/jimmy-dore-interviews-oliver-stone-about-russia-gate-his-recent-interview-with-putin-and-the-backlash-hes-received-for-interviewing-putin\/trackback\/"		};
	/* ]]> */
	</script>
</div>
</main>
</div>
<div id="right-sidebar" itemtype="http://schema.org/WPSideBar" itemscope="itemscope" role="complementary" class="widget-area grid-25 tablet-grid-25 grid-parent sidebar">
<div class="inside-right-sidebar">
<aside id="custom_html-7" class="widget_text widget inner-padding widget_custom_html"><div class="textwidget custom-html-widget">
<script type="text/javascript">
    var page_count = 'off';
    if (typeof OAS_rdl == 'undefined') {
        var OAS_rdl = '';
        var OAS_CA = '';
        page_count = 'on';
        document.write('<script type="text/javascript" src="http://oascentral.investingmediasolutions.com/Scripts/oas_analytics.js"></scr' + 'ipt>');
    } 
</script>
<script type="text/javascript">
    var OAS_url = 'http://oascentral.investingmediasolutions.com';
    var OAS_sitepage = 'InvestmentWatchBlog';
    var OAS_pos = 'TopRight';
    var OAS_searchterms = '';
    var OAS_taxonomy = '';
    if (typeof OAS_RNS == 'undefined'){
        var OAS_RN = new String (Math.random());
        var OAS_RNS = OAS_RN.substring(2, 11);
    }
    if (OAS_searchterms != '') { OAS_searchterms += '&'; }
    if (OAS_taxonomy != '') { OAS_taxonomy = '&' + OAS_taxonomy; }
    if (page_count != 'on') { OAS_taxonomy = '&oas_pv=no_analytics' + OAS_taxonomy; }
    document.write('<script type="text/javascript" src="' + OAS_url + '/RealMedia/ads/adstream_jx.ads/' + OAS_sitepage + '/1' + OAS_RNS + '@' + OAS_pos + '?' + OAS_searchterms + 'XE' + OAS_taxonomy + OAS_rdl + '&if_nt_CookieAccept=' + OAS_CA + '&XE"></scr' + 'ipt>');
</script></div></aside><aside id="text-5" class="widget inner-padding widget_text"> <div class="textwidget"><p>As long as you keep liking, sharing, commenting, clicking on the articles and supporting the blog, we’ll keep standing up, speaking out and fighting back!</p>
</div>
</aside><aside id="text-6" class="widget inner-padding widget_text"> <div class="textwidget"><p><a href="http://www.investmentwatchblog.com/newsletters/">Subscribe to our mailing list and get interesting stuff and updates to your email inbox.</a></p>
</div>
</aside><aside id="custom_html-5" class="widget_text widget inner-padding widget_custom_html"><div class="textwidget custom-html-widget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display: inline-block; width: 300px; height: 600px;" data-ad-client="ca-pub-5827907058615111" data-ad-slot="7185104867"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div></aside><aside id="search-2" class="widget inner-padding widget_search"><form method="get" class="search-form" action="http://www.investmentwatchblog.com/">
<label>
<span class="screen-reader-text">Search for:</span>
<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" title="Search for:">
</label>
<input type="submit" class="search-submit" value="Search">
</form>
</aside> <aside id="recent-posts-2" class="widget inner-padding widget_recent_entries"> <h2 class="widget-title">Recent Posts</h2> <ul>
<li>
<a href="http://www.investmentwatchblog.com/yield-curve-signaling-an-economic-slowdown/">Yield Curve Signaling An Economic Slowdown</a>
</li>
<li>
<a href="http://www.investmentwatchblog.com/could-another-middle-east-war-trigger-a-2nd-american-revolution/">Could Another Middle East War Trigger A 2nd American Revolution?</a>
</li>
<li>
<a href="http://www.investmentwatchblog.com/trump-derangement-syndrome-is-driving-us-toward-wwiii/">Trump Derangement Syndrome Is Driving Us Toward WWIII</a>
</li>
<li>
<a href="http://www.investmentwatchblog.com/can-facebook-be-trusted-now-that-its-founder-has-testified/">Can Facebook be trusted now that its founder has testified?</a>
</li>
<li>
<a href="http://www.investmentwatchblog.com/mass-forced-vaccination-emergency-drill-conducted-on-american-citizens/">Mass Forced Vaccination Emergency Drill Conducted On American Citizens</a>
</li>
</ul>
</aside><aside id="custom_html-3" class="widget_text widget inner-padding widget_custom_html"><div class="textwidget custom-html-widget">
<iframe style="width: 300px; border: none; overflow: hidden;" src="//www.dianomi.com/smartads.epl?id=3374" width="300" height="800" scrolling="NO"></iframe>

<iframe width="300" height="800" scrolling="NO" src="//www.dianomi.com/smartads.epl?id=3374" style="width: 300px; border: none; overflow: hidden;"></iframe>
</div></aside> </div>
</div>
</div>
</div>
<div class="site-footer  ">
<footer class="site-info" itemtype="http://schema.org/WPFooter" itemscope="itemscope">
<div class="inside-site-info grid-container grid-parent">
<div class="copyright-bar">
<span class="copyright">&copy; 2018</span> &bull; <a href="https://generatepress.com" target="_blank" itemprop="url">GeneratePress</a> </div>
</div>
</footer>
</div>
<script>
		var advanced_ads_ga_UID = '';
		advanced_ads_check_adblocker=function(t){function e(t){(window.requestAnimationFrame||window.mozRequestAnimationFrame||window.webkitRequestAnimationFrame||function(t){return setTimeout(t,16)}).call(window,t)}var n=[],a=null;return e(function(){var t=document.createElement("div");t.innerHTML="&nbsp;",t.setAttribute("class","ad_unit ad-unit text-ad text_ad pub_300x250"),t.setAttribute("style","width: 1px !important; height: 1px !important; position: absolute !important; left: 0px !important; top: 0px !important; overflow: hidden !important;"),document.body.appendChild(t),e(function(){var e=window.getComputedStyle&&window.getComputedStyle(t),o=e&&e.getPropertyValue("-moz-binding");a=e&&"none"===e.getPropertyValue("display")||"string"==typeof o&&-1!==o.indexOf("about:");for(var i=0;i<n.length;i++)n[i](a);n=[]})}),function(t){if(null===a)return void n.push(t);t(a)}}(),function(){var t=function(t,e){this.name=t,this.UID=e,this.analyticsObject=null;var n=this,a={hitType:"event",eventCategory:"Advanced Ads",eventAction:"AdBlock",eventLabel:"Yes",nonInteraction:!0,transport:"beacon"};this.analyticsObject="string"==typeof GoogleAnalyticsObject&&"function"==typeof window[GoogleAnalyticsObject]&&window[GoogleAnalyticsObject],!1===this.analyticsObject?(!function(t,e,n,a,o,i,d){t.GoogleAnalyticsObject=o,t[o]=t[o]||function(){(t[o].q=t[o].q||[]).push(arguments)},t[o].l=1*new Date,i=e.createElement(n),d=e.getElementsByTagName(n)[0],i.async=1,i.src="https://www.google-analytics.com/analytics.js",d.parentNode.insertBefore(i,d)}(window,document,"script",0,"_advads_ga"),_advads_ga("create",n.UID,"auto",this.name),_advads_ga(n.name+".send",a)):(window.console&&window.console.log("Advanced Ads Analytics >> using other's variable named `"+GoogleAnalyticsObject+"`"),window[GoogleAnalyticsObject]("create",n.UID,"auto",this.name),window[GoogleAnalyticsObject](n.name+".send",a))};advanced_ads_check_adblocker(function(e){e&&"string"==typeof advanced_ads_ga_UID&&advanced_ads_ga_UID&&new t("advadsTracker",advanced_ads_ga_UID)})}();
		
		</script><div class="wpsr-followbar sr-fb-rm sr-fb-vl"><div class="socializer sr-followbar sr-32px sr-circle sr-zoom sr-pad sr-vertical"><span class="sr-facebook  "><a rel="nofollow" href="https://www.facebook.com/InvestmentWatch-138869856179618/" target="_blank" title="Facebook" style="color: #ffffff"><i class="fa fa-facebook"></i></a></span><span class="sr-twitter  "><a rel="nofollow" href="https://twitter.com/InvestWatchBlog" target="_blank" title="Twitter" style="color: #ffffff"><i class="fa fa-twitter"></i></a></span><span class="sr-email  "><a rel="nofollow" href="http://www.investmentwatchblog.com/newsletters/" target="_blank" title="Email" style="color: #ffffff"><i class="fa fa-envelope"></i></a></span></div><div class="wpsr-fb-close" title="Toggle"><span class="fa wpsr-arrow"></span></div></div>

<script>var wpsr_ajax_url = "http://www.investmentwatchblog.com/wp-admin/admin-ajax.php";</script><div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.8";
  fjs.parentNode.insertBefore(js, fjs);
}(document, "script", "facebook-jssdk"));</script><script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>

<a title="Scroll back to top" rel="nofollow" href="#" class="generate-back-to-top" style="opacity:0;visibility:hidden;" data-scroll-speed="400" data-start-scroll="300">
<i class="fa fa-angle-up" aria-hidden="true"></i>
<span class="screen-reader-text">Scroll back to top</span>
</a><!--[if lte IE 11]>
<script type='text/javascript' src='http://www.investmentwatchblog.com/wp-content/themes/generatepress/js/classList.min.js?ver=2.0.2'></script>
<![endif]-->
<script type='text/javascript' src='http://www.investmentwatchblog.com/wp-content/themes/generatepress/js/menu.min.js?ver=2.0.2'></script>
<script type='text/javascript' src='http://www.investmentwatchblog.com/wp-content/themes/generatepress/js/a11y.min.js?ver=2.0.2'></script>
<script type='text/javascript' src='http://www.investmentwatchblog.com/wp-content/themes/generatepress/js/dropdown.min.js?ver=2.0.2'></script>
<script type='text/javascript' src='http://www.investmentwatchblog.com/wp-content/themes/generatepress/js/back-to-top.min.js?ver=2.0.2'></script>
<script type='text/javascript' src='http://www.investmentwatchblog.com/wp-includes/js/comment-reply.min.js?ver=4.9.5'></script>
<script type='text/javascript' src='http://www.investmentwatchblog.com/wp-content/plugins/wp-socializer/public/js/wp-socializer.min.js?ver=3.3.4'></script>
<script type="text/javascript">

    var disqus_shortname = "investmentwatchblog";
    if (typeof ds_loaded == "undefined") {
        var ds_loaded = false;
    }
    function loadDisqus() {
        var disqus_div = document.getElementById("disqus_thread");
        var top = disqus_div.offsetTop;
        var disqus_data = disqus_div.dataset;
        if ( !ds_loaded && ( window.scrollY || window.pageYOffset ) + window.innerHeight > top ) {
            ds_loaded = true;
            for (var key in disqus_data) {
                if (key.substr(0,6) == "disqus") {
                    window["disqus_" + key.replace("disqus","").toLowerCase()] = disqus_data[key];
								}
                }
                var dsq = document.createElement("script");
                dsq.type = "text/javascript";
                dsq.async = true;
                dsq.src = "http://" + window.disqus_shortname + ".disqus.com/embed.js";
                if(document.getElementById("dcl-hidden-div")) {
                    document.getElementById("dcl-hidden-div").innerHTML = "Loading...";
                }
                (document.getElementsByTagName("head")[0] || document.getElementsByTagName("body")[0]).appendChild(dsq);
            }
        }
					var disqus_div_new = document.getElementById("disqus_thread");
		var divExists = disqus_div_new != null;
                if(document.body.scrollHeight < window.innerHeight){
                    loadDisqus();
                } else if(divExists) {
                    window.onscroll = function() { loadDisqus(); }
                }
	</script><script type='text/javascript'>
                /* <![CDATA[ */
                var hash = window.location.hash;
                var disqus_shortname = 'investmentwatchblog';
                if(hash!==''){
                    var ds_loaded = true;
                    var dcl_loaded = 1;
                    (function() {
                        var dsq = document.createElement('script'); dsq.type = 'text/javascript';
                        dsq.async = true;
                        dsq.src = '//' + disqus_shortname + '.' + 'disqus.com' + '/' + 'embed' + '.js' + '?pname=wordpress&pver=2.84';
                        (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dsq);
                    })();}
                /* ]]> */
            </script>
</body>
</html>
